summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-01-04 21:19:38 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-01-08 16:23:16 +0200
commit1a57bcb8d1a7a49cc8a43596a79d57cd2fbb5dfe (patch)
tree94efe46bd05b546010c6ead62c645070aa8ab3e3 /include/libcamera/meson.build
parentd0fd42a4fde6cf29bae760d553d4a4f9b857810f (diff)
libcamera: Add event notification infrastructure
Add three new classes, EventDispatcher, EventNotifier and Timer, that define APIs for file descriptor event notification and timers. The implementation of the EventDispatcher is meant to be provided to libcamera by the application. The event dispatcher is integrated twith the camera manager to implement automatic registration of timers and events. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index 6f87689e..d7cb55ba 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -1,8 +1,11 @@
libcamera_api = files([
'camera.h',
'camera_manager.h',
+ 'event_dispatcher.h',
+ 'event_notifier.h',
'libcamera.h',
'signal.h',
+ 'timer.h',
])
install_headers(libcamera_api,