summaryrefslogtreecommitdiff
path: root/include/libcamera/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2020-01-02 11:17:39 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-03-06 18:08:37 +0200
commit09ab21b85ad83243878dab898eb0a6d0e85e6780 (patch)
treec9c001bdcc15f47ef7d96e28cfdceae6852f5e46 /include/libcamera/meson.build
parentdd9429f438865c5a48b460b4ce33b3f74f90027f (diff)
libcamera: Add a C++20-compliant std::span<> implementation
C++20 will contain a std::span<> class that provides view over a contiguous sequence of objects, the storage of which is owned by some other object. Add a compatible implementation to the utils namespace. This will be used to implement array controls. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Acked-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'include/libcamera/meson.build')
-rw-r--r--include/libcamera/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/libcamera/meson.build b/include/libcamera/meson.build
index f58c02d2..f47c583c 100644
--- a/include/libcamera/meson.build
+++ b/include/libcamera/meson.build
@@ -14,6 +14,7 @@ libcamera_api = files([
'pixelformats.h',
'request.h',
'signal.h',
+ 'span.h',
'stream.h',
'timer.h',
])