summaryrefslogtreecommitdiff
path: root/include/libcamera/internal/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2020-10-19 19:18:17 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2020-11-03 11:07:21 +0900
commitfcc6d4bd76874585336cb0bbbd369702b59515d2 (patch)
tree7d35d18c516ef49e39cc8bf9e5c9aabfc7bb7dc2 /include/libcamera/internal/meson.build
parent4757ff4ab7b4dac560cad26db12e28ef741c96ff (diff)
libcamera: tracing: Implement tracing infrastructure
Implement tracing infrastructure in libcamera. It takes .tp files, as required by lttng, and generates a tracepoint header and C file, as lttng requires. meson is updated accordingly to get it to compile with the rest of libcamera. Update the documentation accordingly. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'include/libcamera/internal/meson.build')
-rw-r--r--include/libcamera/internal/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/libcamera/internal/meson.build b/include/libcamera/internal/meson.build
index 15010338..6500fe2a 100644
--- a/include/libcamera/internal/meson.build
+++ b/include/libcamera/internal/meson.build
@@ -1,5 +1,14 @@
# SPDX-License-Identifier: CC0-1.0
+subdir('tracepoints')
+
+libcamera_tracepoint_header = custom_target(
+ 'tp_header',
+ input: [ 'tracepoints.h.in', tracepoint_files ],
+ output: 'tracepoints.h',
+ command: [ gen_tracepoints_header, '@OUTPUT@', '@INPUT@' ],
+)
+
libcamera_internal_headers = files([
'byte_stream_buffer.h',
'camera_controls.h',