summaryrefslogtreecommitdiff
path: root/include/libcamera/internal/meson.build
diff options
context:
space:
mode:
authorHan-Lin Chen <hanlinchen@chromium.org>2022-04-27 22:09:27 +0800
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-05-10 00:22:36 +0300
commitfcb0ea001a2d3350068410c3bd2f940694a339a0 (patch)
tree1c62b437e8191237560f77812e9ed8089df0665d /include/libcamera/internal/meson.build
parentc70323e4941542202c34f4fde7d340d1f62d6c9c (diff)
libcamera: Introduce YamlParser as a helper to parse yaml files
Introduce YamlParser as a helper to convert contents of a yaml file to a tree based structure for easier reading, and to avoid writing parser with raw yaml tokens. The class is based on libyaml, and only support reading but not writing a yaml file. The interface is inspired by Json::Value class from jsoncpp: http://jsoncpp.sourceforge.net/class_json_1_1_value.html Signed-off-by: Han-Lin Chen <hanlinchen@chromium.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'include/libcamera/internal/meson.build')
-rw-r--r--include/libcamera/internal/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/libcamera/internal/meson.build b/include/libcamera/internal/meson.build
index c9e055d4..7a780d48 100644
--- a/include/libcamera/internal/meson.build
+++ b/include/libcamera/internal/meson.build
@@ -42,4 +42,5 @@ libcamera_internal_headers = files([
'v4l2_pixelformat.h',
'v4l2_subdevice.h',
'v4l2_videodevice.h',
+ 'yaml_parser.h',
])