summaryrefslogtreecommitdiff
path: root/include/libcamera/internal/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2023-05-11 22:21:02 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2023-06-17 22:52:26 +0100
commit7144fe6f9cdddb69caa33eb753bc173adcb2ad06 (patch)
tree761cb9abb766e7ea081077c34343cc73f6fef3ab /include/libcamera/internal/meson.build
parentf36c05c21e8505c2eed3d2f0bc102b4e5fae372e (diff)
libcamera: camera_manager: Move private implementation to internal
The CameraManager makes use of the Extensible pattern to provide an internal private implementation that is not exposed in the public API. Move the Private declaration to an internal header to make it available from other internal components in preperation for reducing the surface area of the public interface of the CameraManager. Reviewed-by: Jacopo Mondi <jacopo.mondi@ideasonboard.com> Tested-by: Ashok Sidipotu <ashok.sidipotu@collabora.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'include/libcamera/internal/meson.build')
-rw-r--r--include/libcamera/internal/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/libcamera/internal/meson.build b/include/libcamera/internal/meson.build
index d7508805..4b2756a4 100644
--- a/include/libcamera/internal/meson.build
+++ b/include/libcamera/internal/meson.build
@@ -15,6 +15,7 @@ libcamera_internal_headers = files([
'camera.h',
'camera_controls.h',
'camera_lens.h',
+ 'camera_manager.h',
'camera_sensor.h',
'camera_sensor_properties.h',
'control_serializer.h',