summaryrefslogtreecommitdiff
path: root/Documentation/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-11 20:09:51 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2018-12-11 20:28:34 +0200
commit66bb4d388d06a79aa67393a61f46c8ea8665463f (patch)
tree4c131c22dd4c8e770f4a2f693989e3e0cb8e5fa2 /Documentation/meson.build
parent830031892b875e284fa14bb13b5d6bd1e8a9173b (diff)
Documentation: Set install_dir in custom_target()
The custom_target() function accepts an install_dir parameter. Along with setting install to true, this can be used to replace the install_subdir() function. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build7
1 files changed, 3 insertions, 4 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index 578c1cae..49e6f374 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -14,8 +14,7 @@ if sphinx.found()
command: [sphinx, '-W', '-b', 'html', meson.current_source_dir(), '@OUTPUT@'],
input: docs_sources,
output: 'html',
- build_by_default: true)
-
- install_subdir(meson.current_build_dir() + '/html',
- install_dir: 'share/doc/libcamera-@0@'.format(api_version))
+ build_by_default: true,
+ install: true,
+ install_dir: 'share/doc/libcamera-@0@'.format(api_version))
endif