summaryrefslogtreecommitdiff
path: root/Documentation/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2018-11-30 14:49:46 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-01-31 14:54:28 +0000
commit4b44f61c53b2f29bc3f6cec3aa2f5242ecd18ebf (patch)
treea45df2db81be5deb6eb220ae2c6d44163474aa5d /Documentation/meson.build
parent7aeff19555cefed28c49fea73618f3f853c3f1bd (diff)
Documentation: Add linkcheck target
Sphinx provides a run-target to verify external links specified in the documentation. This requires an active connection to be able to validate the links. Add a meson target to integrate the linkcheck facility into our build and test system. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index 9136506f..c4e98924 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -62,4 +62,10 @@ if sphinx.found()
build_by_default : true,
install : true,
install_dir : doc_install_dir)
+
+ custom_target('documentation-linkcheck',
+ command: [sphinx, '-W', '-b', 'linkcheck', meson.current_source_dir(), '@OUTPUT@'],
+ build_always_stale: true,
+ input: docs_sources,
+ output: 'linkcheck')
endif