summaryrefslogtreecommitdiff
path: root/Documentation/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 00:05:30 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-05-23 11:55:45 +0300
commit41adc3f8d39e78eb432bf33ab859d1f5429b85dc (patch)
treef637a6b1e28b2dbb0ebce1274bebef1a8ac678ff /Documentation/meson.build
parent1f32abb995a04b7c67af6d923fea82436e817de1 (diff)
meson: Fix coding style in meson.build files
Consistently go for 4 spaces indentation, and always put a space between the colon in argument lists, as per the examples from the meson documentation. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'Documentation/meson.build')
-rw-r--r--Documentation/meson.build34
1 files changed, 17 insertions, 17 deletions
diff --git a/Documentation/meson.build b/Documentation/meson.build
index 12a99307..629e8531 100644
--- a/Documentation/meson.build
+++ b/Documentation/meson.build
@@ -4,7 +4,7 @@ doc_install_dir = join_paths(get_option('datadir'), 'doc', 'libcamera-@0@'.forma
# Doxygen
#
-doxygen = find_program('doxygen', required: false)
+doxygen = find_program('doxygen', required : false)
if doxygen.found()
cdata = configuration_data()
@@ -12,30 +12,30 @@ if doxygen.found()
cdata.set('TOP_SRCDIR', meson.source_root())
cdata.set('TOP_BUILDDIR', meson.build_root())
- doxyfile = configure_file(input: 'Doxyfile.in',
- output: 'Doxyfile',
- configuration: cdata)
+ doxyfile = configure_file(input : 'Doxyfile.in',
+ output : 'Doxyfile',
+ configuration : cdata)
custom_target('doxygen',
- input: [
+ input : [
doxyfile,
libcamera_api,
libcamera_headers,
libcamera_sources,
],
- output: 'api-html',
- command: [doxygen, doxyfile],
- install: true,
- install_dir: doc_install_dir)
+ output : 'api-html',
+ command : [doxygen, doxyfile],
+ install : true,
+ install_dir : doc_install_dir)
endif
#
# Sphinx
#
-sphinx = find_program('sphinx-build-3', required: false)
+sphinx = find_program('sphinx-build-3', required : false)
if not sphinx.found()
- sphinx = find_program('sphinx-build', required: false)
+ sphinx = find_program('sphinx-build', required : false)
endif
if sphinx.found()
@@ -48,10 +48,10 @@ if sphinx.found()
]
custom_target('documentation',
- command: [sphinx, '-q', '-W', '-b', 'html', meson.current_source_dir(), '@OUTPUT@'],
- input: docs_sources,
- output: 'html',
- build_by_default: true,
- install: true,
- install_dir: doc_install_dir)
+ command : [sphinx, '-q', '-W', '-b', 'html', meson.current_source_dir(), '@OUTPUT@'],
+ input : docs_sources,
+ output : 'html',
+ build_by_default : true,
+ install : true,
+ install_dir : doc_install_dir)
endif