summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorUmang Jain <email@uajain.com>2020-10-28 02:54:46 +0530
committerKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-28 15:52:51 +0000
commitf0421988dc7d91fbd221e2282f839cb51e1a3f8c (patch)
tree137bb03e77eb36acffd94f708d253c2930aaf89f /src/android/meson.build
parent25202dbb7ebbc90551751ff2fef4e876b4923d3e (diff)
android: jpeg: Introduce a simple image thumbnailer
Add a basic image Thumbnailer class for the frames being captured. Currently, the thumbnailer can scale NV12 frames. It shall be used to generate a thumbnail image for EXIF metadata, in the subsequent commit. Signed-off-by: Umang Jain <email@uajain.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
index f72376a0..3d4d3be4 100644
--- a/src/android/meson.build
+++ b/src/android/meson.build
@@ -25,6 +25,7 @@ android_hal_sources = files([
'jpeg/encoder_libjpeg.cpp',
'jpeg/exif.cpp',
'jpeg/post_processor_jpeg.cpp',
+ 'jpeg/thumbnailer.cpp',
])
android_camera_metadata_sources = files([