summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-01-20 01:09:34 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-02-13 13:23:23 +0200
commitda3f50ee9cdb6896b365357b0d35577344f72ba4 (patch)
tree4e3b31244adeb18f0458992153ab77ce47dd1c93 /src/android/meson.build
parent8a8502ec0ea5e64a0c44eb18aac0ecd4b6771e6b (diff)
android: Remove internal thread
Now that libcamera creates threads internally and doesn't rely on an application-provided event loop, remove the thread from the Android Camera HAL layer. The CameraProxy class becomes meaningless, remove it and communicate directly from the CameraHalManager to the CameraDevice. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Acked-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
index 70dfcc1d..5a5a332e 100644
--- a/src/android/meson.build
+++ b/src/android/meson.build
@@ -3,7 +3,7 @@ android_hal_sources = files([
'camera_hal_manager.cpp',
'camera_device.cpp',
'camera_metadata.cpp',
- 'camera_proxy.cpp',
+ 'camera_ops.cpp',
])
android_camera_metadata_sources = files([