summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2020-10-06 17:53:51 +0200
committerJacopo Mondi <jacopo@jmondi.org>2020-10-14 20:10:06 +0200
commit8806863b0bc4498d098e16dda657ab6f8293d208 (patch)
tree78c25412dff79d76fc953fe35f7f97eaaedec01e /src/android/meson.build
parenta55fb80901779ba53a6b5288afb1815d31385a1b (diff)
android: camera_worker: Introduce CameraWorker
The Android camera framework provides for each buffer part of a capture request an acquisition fence the camera HAL is supposed to wait on before using the buffer. As the libcamera HAL runs in the camera service thread, it is not possible to perform a synchronous wait there. Introduce a CameraWorker class that runs an internal thread to wait on a set of fences before queueing a capture request to the libcamera::Camera. Fences completion is handled through a simple poll, similar in implementation to the sync_wait() function provided by libdrm. Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
index 802bb89a..b2b2293c 100644
--- a/src/android/meson.build
+++ b/src/android/meson.build
@@ -21,6 +21,7 @@ android_hal_sources = files([
'camera_metadata.cpp',
'camera_ops.cpp',
'camera_stream.cpp',
+ 'camera_worker.cpp',
'jpeg/encoder_libjpeg.cpp',
'jpeg/exif.cpp',
])