summaryrefslogtreecommitdiff
path: root/src/android/meson.build
diff options
context:
space:
mode:
authorJacopo Mondi <jacopo@jmondi.org>2019-10-27 02:01:08 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-10-30 02:37:37 +0200
commit53eab996809e826bc914e4c34c78fe74d86f8dc4 (patch)
tree26442c7a7115f4d42f82fbb0c6bc3c6c61e79b30 /src/android/meson.build
parent1f1d27cc14bb1ed7b74c541e523d8f77b0a98dbb (diff)
android: Replace ThreadRPC with blocking method call
Use the newly introduced InvocationTypeBlocking message type to replace the blocking message delivery implemented with the ThreadRPC class in the Android camera HAL. Signed-off-by: Jacopo Mondi <jacopo@jmondi.org> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'src/android/meson.build')
-rw-r--r--src/android/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/android/meson.build b/src/android/meson.build
index b5e4eeeb..70dfcc1d 100644
--- a/src/android/meson.build
+++ b/src/android/meson.build
@@ -4,7 +4,6 @@ android_hal_sources = files([
'camera_device.cpp',
'camera_metadata.cpp',
'camera_proxy.cpp',
- 'thread_rpc.cpp'
])
android_camera_metadata_sources = files([