summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-30 11:58:14 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-11-01 18:09:18 +0000
commitbfe714743feaa43501cc5beb2f95bfe3550f9634 (patch)
treeba253e7da0a129eb97320079091ac9b7013cdbee /meson.build
parent10146d79ea272aacb32fe36f57e9969d82dc5132 (diff)
DocumentationUseOnly: Force enable Vivid
To make sure we always build the Vivid pipeline in this branch, explicitly add it to the pipelines build targets. This is not any kind of best practice for pipeline handlers, but is here to ensure that this pipeline is always compiled on this branch who's sole purpose is to use and demonstrate the vivid pipeline handler.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f218b8c2..95088b51 100644
--- a/meson.build
+++ b/meson.build
@@ -169,6 +169,11 @@ if get_option('test') and 'vimc' not in pipelines
pipelines += ['vimc']
endif
+# Force enable the Vivid pipeline on the development branch only.
+if 'vivid' not in pipelines
+ pipelines += ['vivid']
+endif
+
# Utilities are parsed first to provide support for other components.
subdir('utils')