summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-30 11:58:14 +0000
committerBarnabás Pőcze <pobrn@protonmail.com>2025-02-21 16:02:31 +0100
commitf5b077c41d03a31197225b4001ab815ddcc81205 (patch)
tree47e503d08c4ce7e237e7787e7a6a3b18f8587e67 /meson.build
parent9edf73bc8e78db22972d84b0d9f84f4259572cf9 (diff)
DocumentationUseOnly: Force enable Vivid
To make sure we always build the Vivid pipeline in this branch, explicitly add it to the pipelines build targets. This is not any kind of best practice for pipeline handlers, but is here to ensure that this pipeline is always compiled on this branch who's sole purpose is to use and demonstrate the vivid pipeline handler.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5270f626..724ab213 100644
--- a/meson.build
+++ b/meson.build
@@ -245,6 +245,11 @@ if get_option('test')
endforeach
endif
+# Force enable the Vivid pipeline on the development branch only.
+if 'vivid' not in pipelines
+ pipelines += ['vivid']
+endif
+
# Utilities are parsed first to provide support for other components.
subdir('utils')