summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2020-10-30 11:58:14 +0000
committerBarnabás Pőcze <pobrn@protonmail.com>2024-12-09 12:19:20 +0100
commita0a99605f5c9dc8c599a7a2185fc1264194a35d5 (patch)
tree246620fed016e674ac830f6d934b1f11dd6a18a9 /meson.build
parent43edb21015f7825f05e2fdf84f8da61980bfd55f (diff)
DocumentationUseOnly: Force enable Vivid
To make sure we always build the Vivid pipeline in this branch, explicitly add it to the pipelines build targets. This is not any kind of best practice for pipeline handlers, but is here to ensure that this pipeline is always compiled on this branch who's sole purpose is to use and demonstrate the vivid pipeline handler.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 33afbb74..b14ab1de 100644
--- a/meson.build
+++ b/meson.build
@@ -243,6 +243,11 @@ if get_option('test')
endforeach
endif
+# Force enable the Vivid pipeline on the development branch only.
+if 'vivid' not in pipelines
+ pipelines += ['vivid']
+endif
+
# Utilities are parsed first to provide support for other components.
subdir('utils')