summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorStefan Klug <stefan.klug@ideasonboard.com>2024-09-20 12:10:54 +0200
committerStefan Klug <stefan.klug@ideasonboard.com>2024-09-23 13:03:35 +0200
commitf623f3ed645d706ed2a0dd129328b63add0dbf47 (patch)
treef653d2427b164af385290fd60ba898bc283a5e01 /test/meson.build
parentf2842258d10fa509f0ab2227111836eecd184f48 (diff)
libcamera: yaml-parser: Add failing test for unexpected behavior
When accessing a nonexistent key on a dict the YamlObject returns an empty element. This element can happily be cast to a string. This is unexpected. For example the following statement: yamlDict["nonexistent"].get<string>("default") is expected to return "default" but actually returns "". Add a (failing) testcase for that behavior. Signed-off-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 5ed052ed..dcd169a8 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -73,7 +73,7 @@ internal_tests = [
{'name': 'timer-thread', 'sources': ['timer-thread.cpp']},
{'name': 'unique-fd', 'sources': ['unique-fd.cpp']},
{'name': 'utils', 'sources': ['utils.cpp']},
- {'name': 'yaml-parser', 'sources': ['yaml-parser.cpp']},
+ {'name': 'yaml-parser', 'sources': ['yaml-parser.cpp'], 'should_fail': true},
]
internal_non_parallel_tests = [