summaryrefslogtreecommitdiff
path: root/src/libcamera/software_isp/meson.build
diff options
context:
space:
mode:
authorHans de Goede <hdegoede@redhat.com>2024-04-16 11:13:45 +0200
committerKieran Bingham <kieran.bingham@ideasonboard.com>2024-04-16 13:00:21 +0100
commit3755d966485d96e76eef7756222baf02dea960a4 (patch)
tree4cc58115df74a4c0e8d181b25962449fd0f3b428 /src/libcamera/software_isp/meson.build
parent783f92c018afb5ea5e18e75897d3a96577623b64 (diff)
libcamera: software_isp: Add DebayerCpu class
Add CPU based debayering implementation. This initial implementation only supports debayering packed 10 bits per pixel bayer data in the 4 standard bayer orders. Doxygen documentation by Dennis Bonke. Tested-by: Bryan O'Donoghue <bryan.odonoghue@linaro.org> # sc8280xp Lenovo x13s Tested-by: Pavel Machek <pavel@ucw.cz> Reviewed-by: Pavel Machek <pavel@ucw.cz> Co-developed-by: Dennis Bonke <admin@dennisbonke.com> Signed-off-by: Dennis Bonke <admin@dennisbonke.com> Co-developed-by: Andrey Konovalov <andrey.konovalov@linaro.org> Signed-off-by: Andrey Konovalov <andrey.konovalov@linaro.org> Co-developed-by: Pavel Machek <pavel@ucw.cz> Signed-off-by: Pavel Machek <pavel@ucw.cz> Signed-off-by: Hans de Goede <hdegoede@redhat.com> Reviewed-by: Milan Zamazal <mzamazal@redhat.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/software_isp/meson.build')
-rw-r--r--src/libcamera/software_isp/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/software_isp/meson.build b/src/libcamera/software_isp/meson.build
index 6068a418..b63f077f 100644
--- a/src/libcamera/software_isp/meson.build
+++ b/src/libcamera/software_isp/meson.build
@@ -9,5 +9,6 @@ endif
libcamera_sources += files([
'debayer.cpp',
+ 'debayer_cpu.cpp',
'swstats_cpu.cpp',
])