summaryrefslogtreecommitdiff
path: root/src/libcamera/sensor/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-02-23 14:12:14 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-04-24 20:44:25 +0300
commita3acdaf6b78df04efa0028199789f4b27265845b (patch)
tree4ccbb6dd0794aa448b18b95eac3829df0d66ef97 /src/libcamera/sensor/meson.build
parenteb3209902f697571d3363cbe94e75198afeb238f (diff)
libcamera: Add CameraSensor implementation for raw V4L2 sensors
Add a new CameraSensorRaw implementation of the CameraSensor interface tailored to devices that implement the new V4L2 raw camera sensors API. This new class duplicates code from the CameraSensorLegacy class. The two classes will be refactored to share code. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> --- Changes since combined RFC: - Set factory priority explicitly - Set flipsAlterBayerOrder_ - Fix build warning due to missing default case in cfa switch - Check for read-only hblank using V4L2_CTRL_FLAG_READ_ONLY
Diffstat (limited to 'src/libcamera/sensor/meson.build')
-rw-r--r--src/libcamera/sensor/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libcamera/sensor/meson.build b/src/libcamera/sensor/meson.build
index e83020fc..e3c39aaf 100644
--- a/src/libcamera/sensor/meson.build
+++ b/src/libcamera/sensor/meson.build
@@ -4,4 +4,5 @@ libcamera_sources += files([
'camera_sensor.cpp',
'camera_sensor_legacy.cpp',
'camera_sensor_properties.cpp',
+ 'camera_sensor_raw.cpp',
])