summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/meson.build
diff options
context:
space:
mode:
authorDavid Plowman <david.plowman@raspberrypi.com>2021-06-28 13:23:24 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2021-06-28 19:34:46 +0300
commitec5d3142a9452703be93cb336689a9e6163a0f72 (patch)
treede796351846dc87f15224db9e76f9a886f96ecc0 /src/ipa/raspberrypi/meson.build
parent87998e064d701f6ee910234ae9404af401351afa (diff)
libcamera: ipa: raspberrypi: Add support for ov9281 sensor
The necessary tuning file and CamHelper is added for the ov9281 sensor. The ov9281 is a 1280x800 monochrome global shutter sensor. To enable it, please add dtoverlay=ov9281 to the /boot/config.txt file and reboot the Pi. Signed-off-by: David Plowman <david.plowman@raspberrypi.com> Reviewed-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/meson.build')
-rw-r--r--src/ipa/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/meson.build b/src/ipa/raspberrypi/meson.build
index d7203aa0..c9855018 100644
--- a/src/ipa/raspberrypi/meson.build
+++ b/src/ipa/raspberrypi/meson.build
@@ -22,6 +22,7 @@ rpi_ipa_sources = files([
'cam_helper_imx219.cpp',
'cam_helper_imx290.cpp',
'cam_helper_imx477.cpp',
+ 'cam_helper_ov9281.cpp',
'controller/controller.cpp',
'controller/histogram.cpp',
'controller/algorithm.cpp',