summaryrefslogtreecommitdiff
path: root/test/stream/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/stream/meson.build')
-rw-r--r--test/stream/meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/test/stream/meson.build b/test/stream/meson.build
index 3a97868b..a3b19bf5 100644
--- a/test/stream/meson.build
+++ b/test/stream/meson.build
@@ -1,14 +1,14 @@
# SPDX-License-Identifier: CC0-1.0
stream_tests = [
- ['stream_colorspace', 'stream_colorspace.cpp'],
- ['stream_formats', 'stream_formats.cpp'],
+ {'name': 'stream_colorspace', 'sources': ['stream_colorspace.cpp']},
+ {'name': 'stream_formats', 'sources': ['stream_formats.cpp']},
]
foreach test : stream_tests
- exe = executable(test[0], test[1],
+ exe = executable(test['name'], test['sources'],
dependencies : libcamera_public,
link_with : test_libraries,
include_directories : test_includes_internal)
- test(test[0], exe, suite: 'stream')
+ test(test['name'], exe, suite: 'stream')
endforeach