summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index 91bea775..76198e95 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -27,11 +27,13 @@ else
ipa_sign_module = false
endif
+# libyuv, used by the Android adaptation layer and the virtual pipeline handler.
+# Fallback to a subproject if libyuv isn't found, as it's typically not provided
+# by distributions.
libyuv_dep = dependency('libyuv', required : false)
-# Fallback to a subproject if libyuv isn't found, as it's typically not
-# provided by distributions.
-if not libyuv_dep.found()
+if (pipelines.contains('virtual') or get_option('android').allowed()) and \
+ not libyuv_dep.found()
cmake = import('cmake')
libyuv_vars = cmake.subproject_options()