summaryrefslogtreecommitdiff
path: root/src/apps/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/apps/meson.build')
-rw-r--r--src/apps/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/apps/meson.build b/src/apps/meson.build
index 9e4388bd..62cff67e 100644
--- a/src/apps/meson.build
+++ b/src/apps/meson.build
@@ -1,5 +1,15 @@
# SPDX-License-Identifier: CC0-1.0
+opt_cam = get_option('cam')
+opt_lc_compliance = get_option('lc-compliance')
+
+# libevent is needed by cam and lc-compliance. As they are both feature options,
+# they can't be combined with simple boolean logic.
+libevent = dependency('libevent_pthreads', required : opt_cam)
+if not libevent.found()
+ libevent = dependency('libevent_pthreads', required : opt_lc_compliance)
+endif
+
subdir('lc-compliance')
subdir('cam')