summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c6e6a934..9fc5cc52 100644
--- a/meson.build
+++ b/meson.build
@@ -93,6 +93,12 @@ if get_option('test')
subdir('test')
endif
+# Create a symlink from the build root to the source root. This is used when
+# running libcamera from the build directory to locate resources in the source
+# directory (such as IPA configuration files).
+run_command('ln', '-fsT', meson.source_root(),
+ join_paths(meson.build_root(), 'source'))
+
configure_file(output : 'config.h', configuration : config_h)
pkg_mod = import('pkgconfig')