summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 72ad7c8b..0a222ba9 100644
--- a/meson.build
+++ b/meson.build
@@ -35,8 +35,8 @@ common_arguments = [
'-include', 'config.h',
]
-c_arguments = common_arguments
-cpp_arguments = common_arguments
+c_arguments = []
+cpp_arguments = []
if cc.get_id() == 'clang'
# Turn _FORTIFY_SOURCE by default on optimised builds (as it requires -O1
@@ -56,6 +56,9 @@ if cc.get_id() == 'clang'
endif
endif
+c_arguments += common_arguments
+cpp_arguments += common_arguments
+
add_project_arguments(c_arguments, language : 'c')
add_project_arguments(cpp_arguments, language : 'cpp')
add_project_link_arguments(cpp_arguments, language : 'cpp')