summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build30
1 files changed, 16 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 0ef4cdaa..63e45465 100644
--- a/meson.build
+++ b/meson.build
@@ -1,8 +1,8 @@
# SPDX-License-Identifier: CC0-1.0
project('libcamera', 'c', 'cpp',
- meson_version : '>= 0.60',
- version : '0.3.0',
+ meson_version : '>= 0.63',
+ version : '0.3.2',
default_options : [
'werror=true',
'warning_level=2',
@@ -90,11 +90,21 @@ if cc.has_header_symbol('sys/mman.h', 'memfd_create', prefix : '#define _GNU_SOU
config_h.set('HAVE_MEMFD_CREATE', 1)
endif
+ioctl_posix_test = '''
+#include <sys/ioctl.h>
+int ioctl (int, int, ...);
+'''
+
+if cc.compiles(ioctl_posix_test)
+ config_h.set('HAVE_POSIX_IOCTL', 1)
+endif
+
if cc.has_header_symbol('stdlib.h', 'secure_getenv', prefix : '#define _GNU_SOURCE')
config_h.set('HAVE_SECURE_GETENV', 1)
endif
common_arguments = [
+ '-Wmissing-declarations',
'-Wshadow',
'-include', meson.current_build_dir() / 'config.h',
]
@@ -136,16 +146,8 @@ if cc.get_id() == 'clang'
endif
if cc.get_id() == 'gcc'
- if cc.version().version_compare('<8')
- error('gcc version is too old, libcamera requires 8.0 or newer')
- endif
-
- # On gcc 8, the file system library is provided in a separate static
- # library.
if cc.version().version_compare('<9')
- cpp_arguments += [
- '-lstdc++fs',
- ]
+ error('gcc version is too old, libcamera requires 9.0 or newer')
endif
# gcc 13 implements the C++23 version of automatic move from local
@@ -209,7 +211,7 @@ pipelines_support = {
'mali-c55': arch_arm,
'rkisp1': arch_arm,
'rpi/vc4': arch_arm,
- 'simple': arch_arm,
+ 'simple': ['any'],
'uvcvideo': ['any'],
'vimc': ['test'],
}
@@ -276,8 +278,8 @@ py_mod.find_installation('python3', modules : py_modules)
summary({
'Enabled pipelines': pipelines,
'Enabled IPA modules': enabled_ipa_names,
- 'Controls files': controls_files,
- 'Properties files': properties_files,
+ 'Controls files': controls_files_names,
+ 'Properties files': properties_files_names,
'Hotplug support': libudev.found(),
'Tracing support': tracing_enabled,
'Android support': android_enabled,