summaryrefslogtreecommitdiff
path: root/test/v4l2_videodevice/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2022-04-06 13:35:54 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-04-06 15:44:39 +0300
commiteea1c9c6319c63933cc47a7694b14729b4841928 (patch)
tree1ebc1fded4a4f219a6635e7db01751850e9f93e2 /test/v4l2_videodevice/meson.build
parent04faa8477abdaf1dafad3fdbe9dc58326e9126d2 (diff)
test: v4l2_videodevice: Verify the Dequeue Watchdog
Add a test that captures 5 frames, with a short (5ms) watchdog. The default framerate of the VIMC pipeline should ensure that we never meet this watchdog, and the timeout should activate. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/v4l2_videodevice/meson.build')
-rw-r--r--test/v4l2_videodevice/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/v4l2_videodevice/meson.build b/test/v4l2_videodevice/meson.build
index 643f82ed..7a26f53d 100644
--- a/test/v4l2_videodevice/meson.build
+++ b/test/v4l2_videodevice/meson.build
@@ -6,6 +6,7 @@ v4l2_videodevice_tests = [
['double_open', 'double_open.cpp'],
['controls', 'controls.cpp'],
['formats', 'formats.cpp'],
+ ['dequeue_watchdog', 'dequeue_watchdog.cpp'],
['request_buffers', 'request_buffers.cpp'],
['buffer_cache', 'buffer_cache.cpp'],
['stream_on_off', 'stream_on_off.cpp'],