summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-08-18 03:11:27 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-08-19 19:06:37 +0300
commitfd0087b5d8608eb1dc1e1a3da5ddafd83d43fc79 (patch)
treeddaeac42ef501be42b40ab8cd40714cf107cfc0d /test/meson.build
parent8c9deeb30fa6930019788b619ad9081d30c6a6e2 (diff)
test: Get event dispatcher from current thread
For all tests that don't otherwise require access to the camera manager, get the event dispatcher from the current thread instead of the camera manager. This prepares for the removal of CameraManager::instance(). Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/meson.build b/test/meson.build
index 05265b7d..84722cce 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -13,22 +13,22 @@ subdir('v4l2_subdevice')
subdir('v4l2_videodevice')
public_tests = [
- ['event', 'event.cpp'],
- ['event-dispatcher', 'event-dispatcher.cpp'],
['geometry', 'geometry.cpp'],
['list-cameras', 'list-cameras.cpp'],
['signal', 'signal.cpp'],
- ['timer', 'timer.cpp'],
]
internal_tests = [
['camera-sensor', 'camera-sensor.cpp'],
+ ['event', 'event.cpp'],
+ ['event-dispatcher', 'event-dispatcher.cpp'],
['event-thread', 'event-thread.cpp'],
['message', 'message.cpp'],
['object', 'object.cpp'],
['object-invoke', 'object-invoke.cpp'],
['signal-threads', 'signal-threads.cpp'],
['threads', 'threads.cpp'],
+ ['timer', 'timer.cpp'],
['timer-thread', 'timer-thread.cpp'],
]