summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-19 00:27:42 +0100
committerKieran Bingham <kieran.bingham@ideasonboard.com>2021-06-25 16:11:11 +0100
commite228c290c956ac7823fb9347be8ea957cf6d6172 (patch)
treee60e343876c9a86568a5a1c178c6fbda73cdc554 /test/meson.build
parentb71e8c2f39d823891aab4c681cccab9af5a49406 (diff)
libcamera/base: Validate internal headers as private
Headers which must not be exposed as part of the public libcamera API should include base/private.h. Any interface which includes the private.h header will only be able to build if the libcamera_private dependency is used (or the libcamera_base_private dependency directly). Build targets which are intended to use the private API's will use the libcamera_private to handle the automatic definition of the inclusion guard. Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index 045ad2a2..b8615e0f 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -64,7 +64,7 @@ endforeach
foreach t : internal_tests
exe = executable(t[0], t[1],
- dependencies : libcamera_dep,
+ dependencies : libcamera_private,
link_with : test_libraries,
include_directories : test_includes_internal)