summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-06-11 16:13:39 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-06-12 15:10:38 +0300
commitb2b3599b5b0673901bbce958bd9802b9d6313fcf (patch)
treeb7d40b647bfdb8431ad5864e9c96a0f0d40f53a7 /test/meson.build
parent846d4c7d3ee7ca059074b2c2d3aeaa941c3f0870 (diff)
tests: Add CameraSensor class test
Add a test to verify media bus codes, sizes and resolution retrieval through the CameraSensor API based on the Sensor A in the vimc pipeline. Also check that the getFormat() method returns the expected media bus code and size. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 609aeab8..25f181c2 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -17,6 +17,7 @@ public_tests = [
]
internal_tests = [
+ ['camera-sensor', 'camera-sensor.cpp'],
]
foreach t : public_tests