summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-10 19:59:13 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-11 11:57:37 +0300
commita1b1551446f26e942f7784406c6ea824b3914a53 (patch)
treee0c08de319fd2e2b49eaf5e12637d14d12dfc705 /test/meson.build
parent851eaeb9cd5dcdc282f859fd0047867a3f1d57ec (diff)
test: Add test case for signal delivery across threads
The test case creates a receiver inheriting from Object, connects a signal to one of its slot, moves the receiver to a different thread, emits the signal and verifies that it gets delivered in the correct thread with the expected value. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 1f87319a..60ce9601 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -22,6 +22,7 @@ public_tests = [
internal_tests = [
['camera-sensor', 'camera-sensor.cpp'],
['message', 'message.cpp'],
+ ['signal-threads', 'signal-threads.cpp'],
['threads', 'threads.cpp'],
]