summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2019-06-20 03:21:15 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-02 02:25:59 +0300
commita00fdabacdd093c3eccb3d44155e151f59d783bf (patch)
tree6f256d877d54beec28fca6a4ce8d610680ed558b /test/meson.build
parent13dd7a01ecbe7198bbefc3b61168333b6a2bb2d8 (diff)
test: ipc: unix: Add test for IPCUnixSocket
Test that the IPC supports sending data and file descriptors over the IPC medium. To be able to execute the test two parts are needed, one to drive the test and act as the libcamera (master) and a one to act as the IPA (slave). The master drives the testing posting requests to the slave to process and sometimes respond to. A few different tests are performed. - Master sends an array to the slave which responds with a reversed copy of the array. The master verifies that a reversed array is returned. - Master tries to send an empty message making sure that the send call fails. - Master sends a list of file descriptors and ask the slave to calculate and respond with the sum of the size of the files. The master verifies that the calculated size is correct. - Master sends a pre-computed size and a list of file descriptors and asks the slave to verify that the pre-computed size matches the sum of the size of the file descriptors. - Master sends two file descriptors and asks the slave to join the file contents in a new file and respond with its file descriptor. The master then verifies that the content of the returned file descriptor matches the order of the original two files. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index c36ac247..3666f6b2 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -2,6 +2,7 @@ subdir('libtest')
subdir('camera')
subdir('ipa')
+subdir('ipc')
subdir('media_device')
subdir('pipeline')
subdir('stream')