summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorUmang Jain <email@uajain.com>2020-07-31 18:14:18 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-07-31 23:33:35 +0300
commit9c5f82139689a0133f8c253100762511af2e3a6e (patch)
tree99bc9e55e5b5805e2b3660fa66f878f224f92633 /test/meson.build
parent9558886f7a852155e6a911afa81df6e77b0aa68d (diff)
tests: Add a test case for the Object::deleteLater() API, to verify
- the object is deleted from the correct thread - multiple deleteLater() calls delete the object once only Signed-off-by: Umang Jain <email@uajain.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index c0fb9bdf..77518715 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -33,6 +33,7 @@ internal_tests = [
['hotplug-cameras', 'hotplug-cameras.cpp'],
['message', 'message.cpp'],
['object', 'object.cpp'],
+ ['object-delete', 'object-delete.cpp'],
['object-invoke', 'object-invoke.cpp'],
['pixel-format', 'pixel-format.cpp'],
['signal-threads', 'signal-threads.cpp'],