summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorUmang Jain <email@uajain.com>2020-06-16 19:45:39 +0000
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-06-17 00:27:59 +0300
commit8960ef9715cfb38a3b205d7916662f31df5ddd35 (patch)
tree13356b31aaf1d3ad172b5d8402f7bdc42c9ac06f /test/meson.build
parent7055e96ecc9144390a259e4e23be7fb77ca93364 (diff)
tests: Introduce hotplug hot-unplug unit test
This test checks the code-paths for camera's hotplugged and unplugged support. It is based on bind/unbind of a UVC device from sysfs. Hence, this test requires root permissions to run and should have at least one already bound UVC device present in the system. Signed-off-by: Umang Jain <email@uajain.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index bd7da147..a8688131 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -30,6 +30,7 @@ internal_tests = [
['event-thread', 'event-thread.cpp'],
['file', 'file.cpp'],
['file-descriptor', 'file-descriptor.cpp'],
+ ['hotplug-cameras', 'hotplug-cameras.cpp'],
['message', 'message.cpp'],
['object', 'object.cpp'],
['object-invoke', 'object-invoke.cpp'],