summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-10 19:59:13 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2019-07-11 11:57:37 +0300
commit851eaeb9cd5dcdc282f859fd0047867a3f1d57ec (patch)
tree2344d0030409411ddd1f4900d218be564759bf25 /test/meson.build
parenta7fb1db1fa263ddcc200bad5b1e223e8e7449f2f (diff)
test: Add Message test case
The Message class test creates a receiver inheriting from Object, moves it to a different thread, sends a message to the receiver and verifies that the message is delivered in the correct thread. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Niklas Söderlund <niklas.soderlund@ragnatech.se>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index bd0e0d98..1f87319a 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -21,6 +21,7 @@ public_tests = [
internal_tests = [
['camera-sensor', 'camera-sensor.cpp'],
+ ['message', 'message.cpp'],
['threads', 'threads.cpp'],
]