summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorStefan Klug <stefan.klug@ideasonboard.com>2024-09-20 12:13:41 +0200
committerStefan Klug <stefan.klug@ideasonboard.com>2024-09-23 13:03:35 +0200
commit6b67094cd231548df3a42d72351ca9e8841b7033 (patch)
treef2ef727891e69439ad9d4c2999e3d675c07af939 /test/meson.build
parentf623f3ed645d706ed2a0dd129328b63add0dbf47 (diff)
libcamera: yaml-parser: Differentiate between empty and empty string
When accessing a nonexistent key on a dict the YamlObject returns an empty element. This element can happily be cast to a string which is unexpected. For example the following statement: yamlDict["nonexistent"].get<string>("default") is expected to return "default" but actually returns "". Fix this by introducing an empty type to distinguish between an empty YamlObject and a YamlObject of type value containing an empty string. For completeness add an isEmpty() function and an explicit cast to bool to be able to test for that type. Extend the tests accordingly. Signed-off-by: Stefan Klug <stefan.klug@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/meson.build b/test/meson.build
index dcd169a8..5ed052ed 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -73,7 +73,7 @@ internal_tests = [
{'name': 'timer-thread', 'sources': ['timer-thread.cpp']},
{'name': 'unique-fd', 'sources': ['unique-fd.cpp']},
{'name': 'utils', 'sources': ['utils.cpp']},
- {'name': 'yaml-parser', 'sources': ['yaml-parser.cpp'], 'should_fail': true},
+ {'name': 'yaml-parser', 'sources': ['yaml-parser.cpp']},
]
internal_non_parallel_tests = [