summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorNiklas Söderlund <niklas.soderlund@ragnatech.se>2020-10-27 00:59:28 +0100
committerNiklas Söderlund <niklas.soderlund@ragnatech.se>2021-01-29 15:35:28 +0100
commit5023ad293d659d9084d901b20c3cb34977fe1963 (patch)
tree788573f857b98cf258608e3726aa79aa50293b2c /test/meson.build
parent3d4b7b0059116f5f151dec5090ec0e18bd401f24 (diff)
test: delayed_controls: Add test case for DelayedControls
Add a test case for DelayedControls that exercises the setting of controls and reading back what controls were used for a particular frame. Also exercise corner cases such as a V4L2 device that does not reset its sequence number to 0 at stream on and sequence number wrapping around the uint32_t value space. Signed-off-by: Niklas Söderlund <niklas.soderlund@ragnatech.se> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index 7f0682ad..065c5586 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -29,6 +29,7 @@ public_tests = [
internal_tests = [
['byte-stream-buffer', 'byte-stream-buffer.cpp'],
['camera-sensor', 'camera-sensor.cpp'],
+ ['delayed_contols', 'delayed_contols.cpp'],
['event', 'event.cpp'],
['event-dispatcher', 'event-dispatcher.cpp'],
['event-thread', 'event-thread.cpp'],