summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorPaul Elder <paul.elder@ideasonboard.com>2019-07-13 04:29:12 +0900
committerPaul Elder <paul.elder@ideasonboard.com>2019-07-17 14:36:35 +0900
commit4cdabcddc5bd5b469c55090c9e51f4e1bf386d75 (patch)
tree272e446fc3ed1a000f526b6ee1029d60ea4f45cf /test/meson.build
parent42760092e7f0c34c9e8b0aef0db872b48e3d9367 (diff)
test: logging: add logging process test
Add a test to test that logging works in isolated child processes. Only logSetFile is tested, because stdout and stderr are closed for isolated child processes, and syslog and the none logging destinations are expected to be the same as non-isolated processes. Signed-off-by: Paul Elder <paul.elder@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
index ad1a2f2a..658f283e 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -23,6 +23,7 @@ public_tests = [
internal_tests = [
['camera-sensor', 'camera-sensor.cpp'],
['log', 'log.cpp'],
+ ['log_process', 'log_process.cpp'],
['message', 'message.cpp'],
['signal-threads', 'signal-threads.cpp'],
['threads', 'threads.cpp'],