summaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2022-01-19 00:09:59 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-01-19 11:09:35 +0000
commit2b69ad550cfd21da67766f3d7a16cc6a31177820 (patch)
tree1c23251bba774f82d4800bca5147283b9c06c8f3 /test/meson.build
parent7b84a17e213891f9c32b4b3d258c1c8343fc9c8a (diff)
test: Ensure CameraTest tests are not run in parallel
The fence and mapped-buffer tests both use the VIMC test device and must not be run at the same time. Split these tests to a new group to force their isolation from running in parallel. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build16
1 files changed, 14 insertions, 2 deletions
diff --git a/test/meson.build b/test/meson.build
index 2c9487e2..fd4c5ca0 100644
--- a/test/meson.build
+++ b/test/meson.build
@@ -39,11 +39,9 @@ internal_tests = [
['event', 'event.cpp'],
['event-dispatcher', 'event-dispatcher.cpp'],
['event-thread', 'event-thread.cpp'],
- ['fence', 'fence.cpp'],
['file', 'file.cpp'],
['flags', 'flags.cpp'],
['hotplug-cameras', 'hotplug-cameras.cpp'],
- ['mapped-buffer', 'mapped-buffer.cpp'],
['message', 'message.cpp'],
['object', 'object.cpp'],
['object-delete', 'object-delete.cpp'],
@@ -58,6 +56,11 @@ internal_tests = [
['utils', 'utils.cpp'],
]
+internal_non_parallel_tests = [
+ ['fence', 'fence.cpp'],
+ ['mapped-buffer', 'mapped-buffer.cpp'],
+]
+
foreach t : public_tests
exe = executable(t[0], t[1],
dependencies : libcamera_public,
@@ -75,3 +78,12 @@ foreach t : internal_tests
test(t[0], exe)
endforeach
+
+foreach t : internal_non_parallel_tests
+ exe = executable(t[0], t[1],
+ dependencies : libcamera_private,
+ link_with : test_libraries,
+ include_directories : test_includes_internal)
+
+ test(t[0], exe, is_parallel : false)
+endforeach