summaryrefslogtreecommitdiff
path: root/test/gstreamer/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-06-24 17:03:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2024-06-26 12:07:11 +0300
commit6fc5f90f1635b635788bb16080f21c736d1bb359 (patch)
treea6fa0208d20414e311ec3077c7d15e4227676f6f /test/gstreamer/meson.build
parent7817f9e0cf2fa5f2bf9a1938832600fa95bdeda7 (diff)
test: gstreamer: Include missing sanitizer/asan_interface.h header
The GStreamer tests define a __asan_default_options() function to influence the behaviour of ASan. The function is declared in sanitizer/asan_interface.h, but we don't include the header. This will cause missing declaration warnings when we enable the -Wmissing-declarations option. Include the header to fix the issue. It can't be done unconditionally as not all toolchains provide ASan, so check for its availability at configuration time. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'test/gstreamer/meson.build')
-rw-r--r--test/gstreamer/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/gstreamer/meson.build b/test/gstreamer/meson.build
index f3ba5a23..37ad125e 100644
--- a/test/gstreamer/meson.build
+++ b/test/gstreamer/meson.build
@@ -11,8 +11,15 @@ gstreamer_tests = [
]
gstreamer_dep = dependency('gstreamer-1.0', required : true)
+gstreamer_test_args = []
+
+if asan_enabled
+ gstreamer_test_args += ['-D', 'HAVE_ASAN=1']
+endif
+
foreach test : gstreamer_tests
exe = executable(test['name'], test['sources'], 'gstreamer_test.cpp',
+ cpp_args : gstreamer_test_args,
dependencies : [libcamera_private, gstreamer_dep],
link_with : test_libraries,
include_directories : test_includes_internal)
an> // different will need to over-ride the default method provided. // // A method to query if the sensor outputs embedded data that can be parsed. // // A parser to parse the embedded data buffers provided by some sensors (for // example, the imx219 does; the ov5647 doesn't). This allows us to know for // sure the exposure and gain of the frame we're looking at. CamHelper // provides methods for converting analogue gains to and from the sensor's // native gain codes. // // Finally, a set of methods that determine how to handle the vagaries of // different camera modules on start-up or when switching modes. Some // modules may produce one or more frames that are not yet correctly exposed, // or where the metadata may be suspect. We have the following methods: // HideFramesStartup(): Tell the pipeline handler not to return this many // frames at start-up. This can also be used to hide initial frames // while the AGC and other algorithms are sorting themselves out. // HideFramesModeSwitch(): Tell the pipeline handler not to return this // many frames after a mode switch (other than start-up). Some sensors // may produce innvalid frames after a mode switch; others may not. // MistrustFramesStartup(): At start-up a sensor may return frames for // which we should not run any control algorithms (for example, metadata // may be invalid). // MistrustFramesModeSwitch(): The number of frames, after a mode switch // (other than start-up), for which control algorithms should not run // (for example, metadata may be unreliable). class CamHelper { public: static CamHelper *Create(std::string const &cam_name); CamHelper(MdParser *parser, unsigned int frameIntegrationDiff); virtual ~CamHelper(); void SetCameraMode(const CameraMode &mode); MdParser &Parser() const { return *parser_; } uint32_t ExposureLines(double exposure_us) const; double Exposure(uint32_t exposure_lines) const; // in us virtual uint32_t GetVBlanking(double &exposure_us, double minFrameDuration, double maxFrameDuration) const; virtual uint32_t GainCode(double gain) const = 0; virtual double Gain(uint32_t gain_code) const = 0; virtual void GetDelays(int &exposure_delay, int &gain_delay, int &vblank_delay) const; virtual bool SensorEmbeddedDataPresent() const; virtual unsigned int HideFramesStartup() const; virtual unsigned int HideFramesModeSwitch() const; virtual unsigned int MistrustFramesStartup() const; virtual unsigned int MistrustFramesModeSwitch() const; protected: MdParser *parser_; CameraMode mode_; private: bool initialized_; /* * Smallest difference between the frame length and integration time, * in units of lines. */ unsigned int frameIntegrationDiff_; }; // This is for registering camera helpers with the system, so that the // CamHelper::Create function picks them up automatically. typedef CamHelper *(*CamHelperCreateFunc)(); struct RegisterCamHelper { RegisterCamHelper(char const *cam_name, CamHelperCreateFunc create_func); }; } // namespace RPi