summaryrefslogtreecommitdiff
path: root/src/v4l2/meson.build
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2022-01-03 22:49:13 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-02-04 09:39:46 +0000
commitb7d48634c5d389eddd761d888663e2c01232b784 (patch)
treebc70b3aaa0bd730ee868cd3fab84841a4bafc215 /src/v4l2/meson.build
parente526a57d09a3cb9fe226e70f896b4beaa8f9180a (diff)
v4l2: Provide libcamerify wrapper script
Support easier usage of the v4l2 compatibility layer with a script that handles the LD_PRELOAD for applications. The wrapper can be prefixed to launch any application with the preload set: $ libcamera-v4l2 v4l2-ctl --list-devices \_SB_.PCI0.GP13.XHC0.RHUB.PRT4- (libcamera:0): /dev/video0 platform/vimc.0 Sensor B (libcamera:1): /dev/video2 /dev/video3 /dev/video4 Specifying '-d' once before the command to run will enable V4L2Compat layer debug output from libcamera. Specifying '-d' twice will enable all debug levels from all libcamera components and provide a very detailed log for analysis. Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'src/v4l2/meson.build')
-rw-r--r--src/v4l2/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/v4l2/meson.build b/src/v4l2/meson.build
index f78497b6..f132103c 100644
--- a/src/v4l2/meson.build
+++ b/src/v4l2/meson.build
@@ -33,3 +33,14 @@ v4l2_compat = shared_library('v4l2-compat',
install : true,
dependencies : [libcamera_private, libdl],
cpp_args : v4l2_compat_cpp_args)
+
+# Provide a wrapper script to support easily loading applications with the V4L2
+# adaptation layer.
+
+cdata = configuration_data()
+cdata.set('LIBCAMERA_V4L2_SO', get_option('prefix') / get_option('libdir') / 'v4l2-compat.so')
+
+configure_file(input : 'libcamerify.in',
+ output : 'libcamerify',
+ configuration : cdata,
+ install_dir : get_option('bindir'))