summaryrefslogtreecommitdiff
path: root/src/qcam/meson.build
diff options
context:
space:
mode:
authorUtkarsh Tiwari <utkarsh02t@gmail.com>2022-08-07 00:34:30 +0530
committerUtkarsh Tiwari <utkarsh02t@gmail.com>2022-09-05 12:04:59 +0530
commitf03da23b56bed065dace3cf3e7bf027f700e1085 (patch)
treec3db3f6c78aab3f76e0524393dca5747ce4a077a /src/qcam/meson.build
parentf1776100f55e70320a8938586bc8bf2f242addd4 (diff)
qcam: Use QDialog for selection of cameras at startup
Currently we use QInputDialog convenience dialogs to allow the user to select a camera. This doesn't allow adding of more information (such as camera location, model etc). Create a QDialog with a QFormLayout that shows a QComboBox with camera Ids. Use a QDialogButtonBox to provide buttons for accepting and cancelling the action. The CameraSelectorDialog is only initialized the first time when the MainWindow is created. From this commit we cease to auto select the camera if only a single camera is available to libcamera. We would always display the selection dialog with the exception being that being if the camera is supplied on the command line. Signed-off-by: Utkarsh Tiwari <utkarsh02t@gmail.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/qcam/meson.build')
-rw-r--r--src/qcam/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/qcam/meson.build b/src/qcam/meson.build
index c46f4631..61861ea6 100644
--- a/src/qcam/meson.build
+++ b/src/qcam/meson.build
@@ -18,6 +18,7 @@ qcam_sources = files([
'../cam/image.cpp',
'../cam/options.cpp',
'../cam/stream_options.cpp',
+ 'cam_select_dialog.cpp',
'format_converter.cpp',
'main.cpp',
'main_window.cpp',
@@ -26,6 +27,7 @@ qcam_sources = files([
])
qcam_moc_headers = files([
+ 'cam_select_dialog.h',
'main_window.h',
'viewfinder_qt.h',
])