summaryrefslogtreecommitdiff
path: root/src/libcamera/pipeline/raspberrypi/data/meson.build
diff options
context:
space:
mode:
authorNaushir Patuck <naush@raspberrypi.com>2023-01-27 15:43:14 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2023-01-31 16:54:36 +0000
commit8c53b2498bbebde229920e7994feab76a0018c2b (patch)
treeceac6dda68b68cddd8bfba0d81574f6eac2c9565 /src/libcamera/pipeline/raspberrypi/data/meson.build
parent8b267c24a017e0fd81cd3fd1b9d439d76373d096 (diff)
pipeline: raspberrypi: Read config parameters from a file
Add the ability to read the platform configuration parameters from a config file provided by the user through the LIBCAMERA_RPI_CONFIG_FILE environment variable. Use the PipelineHandler::configurationFile() helper to determine the full path of the file. Provide an example configuration file named example.yaml. Currently two parameters are available through the json file: "min_unicam_buffers" The minimum number of internal Unicam buffers to allocate. "min_total_unicam_buffers" The minimum number of internal + external Unicam buffers that must be allocated. Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: David Plowman <david.plowman@raspberrypi.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/libcamera/pipeline/raspberrypi/data/meson.build')
-rw-r--r--src/libcamera/pipeline/raspberrypi/data/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/libcamera/pipeline/raspberrypi/data/meson.build b/src/libcamera/pipeline/raspberrypi/data/meson.build
new file mode 100644
index 00000000..1c70433b
--- /dev/null
+++ b/src/libcamera/pipeline/raspberrypi/data/meson.build
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: CC0-1.0
+
+conf_files = files([
+ 'example.yaml',
+])
+
+install_data(conf_files,
+ install_dir : pipeline_data_dir / 'raspberrypi')