summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/meson.build
diff options
context:
space:
mode:
authorNick Hollinghurst <nick.hollinghurst@raspberrypi.com>2023-01-23 15:49:31 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2023-01-30 16:30:44 +0000
commitcc010b0c35bfa0eee0bafba6a5803d1405542456 (patch)
tree5e1179f74abe4f4eca76fa5f6eb3e541f4e2133f /src/ipa/raspberrypi/meson.build
parent8418473c5178c112d279d7b9ffab3a61f6306693 (diff)
ipa: raspberrypi: First version of autofocus algorithm using PDAF
Provide the first version of the Raspberry Pi autofocus algorithm. This implementation uses a hybrid of contrast detect autofocus (CDAF) and phase detect autofocus (PDAF) statistics. PDAF is always preferred over CDAF due to having less "hunting" behavior. Signed-off-by: Nick Hollinghurst <nick.hollinghurst@raspberrypi.com> Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: David Plowman <david.plowman@raspberrypi.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/meson.build')
-rw-r--r--src/ipa/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/meson.build b/src/ipa/raspberrypi/meson.build
index 517d815b..4e268953 100644
--- a/src/ipa/raspberrypi/meson.build
+++ b/src/ipa/raspberrypi/meson.build
@@ -27,6 +27,7 @@ rpi_ipa_sources = files([
'controller/controller.cpp',
'controller/histogram.cpp',
'controller/algorithm.cpp',
+ 'controller/rpi/af.cpp',
'controller/rpi/alsc.cpp',
'controller/rpi/awb.cpp',
'controller/rpi/sharpen.cpp',