summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/meson.build
diff options
context:
space:
mode:
authorNick Hollinghurst <nick.hollinghurst@raspberrypi.com>2023-01-23 15:49:34 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2023-01-30 16:30:44 +0000
commit952ef94ed78d71625219cbc3705efe2ae6301d39 (patch)
tree5a73dacdbb6a2e752c528cefd00543f23f0507e6 /src/ipa/raspberrypi/meson.build
parent2fb0f25019632650cf677405f62a01c4990ac7c2 (diff)
ipa: raspberrypi: Add support for the Sony IMX708 sensor
Add support for Raspberry Pi Camera 3 modules (Sony IMX708 camera sensor) to the Raspberry Pi IPA. These modules are available in either normal or wide angle lens, both with IR or no IR cut options, giving a total for 4 variants. Provide IQ tuning files for all four variants. The IMX708 camera helper additionally parses PDAF and HDR histogram data that is provided in the embedded data stream from Unicam. Signed-off-by: Nick Hollinghurst <nick.hollinghurst@raspberrypi.com> Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: David Plowman <david.plowman@raspberrypi.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/meson.build')
-rw-r--r--src/ipa/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/meson.build b/src/ipa/raspberrypi/meson.build
index 4e268953..9230e17b 100644
--- a/src/ipa/raspberrypi/meson.build
+++ b/src/ipa/raspberrypi/meson.build
@@ -23,6 +23,7 @@ rpi_ipa_sources = files([
'cam_helper_imx296.cpp',
'cam_helper_imx477.cpp',
'cam_helper_imx519.cpp',
+ 'cam_helper_imx708.cpp',
'cam_helper_ov9281.cpp',
'controller/controller.cpp',
'controller/histogram.cpp',