summaryrefslogtreecommitdiff
path: root/src/ipa/raspberrypi/meson.build
diff options
context:
space:
mode:
authorDavid Plowman <david.plowman@raspberrypi.com>2020-05-28 15:51:32 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2020-06-25 17:47:51 +0300
commit23e15e72f9745d4a11f41b366ff3c9e3dca51bf0 (patch)
treeab6b25be3144e0d5ea88b8993879735b6c764de8 /src/ipa/raspberrypi/meson.build
parent0952f2014d1f08d1e5228f90680af16cb66653a6 (diff)
ipa: rpi: Add "focus" algorithm
Adds FocusStatus to the image metadata, containing contrast measurements across the image. Optionally also prints a contrast measure to the console, to aid in manual adjustment of the lens. Note that it is not an actual auto-focus algorithm that can drive a lens! Signed-off-by: David Plowman <david.plowman@raspberrypi.com> Signed-off-by: Naushir Patuck <naush@raspberrypi.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/ipa/raspberrypi/meson.build')
-rw-r--r--src/ipa/raspberrypi/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipa/raspberrypi/meson.build b/src/ipa/raspberrypi/meson.build
index 697902e9..9445cd09 100644
--- a/src/ipa/raspberrypi/meson.build
+++ b/src/ipa/raspberrypi/meson.build
@@ -29,6 +29,7 @@ rpi_ipa_sources = files([
'controller/rpi/awb.cpp',
'controller/rpi/sharpen.cpp',
'controller/rpi/black_level.cpp',
+ 'controller/rpi/focus.cpp',
'controller/rpi/geq.cpp',
'controller/rpi/noise.cpp',
'controller/rpi/lux.cpp',