summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorQuentin Schulz <quentin.schulz@theobroma-systems.com>2022-07-26 15:20:51 +0200
committerJacopo Mondi <jacopo@jmondi.org>2022-07-26 17:09:55 +0200
commitc698473440abee7330c76d2370c3c01ecc48b8e3 (patch)
tree740b9b24328295b164db661e886bfee398ed33d1 /meson.build
parent49e85fbe9c3bf59c99f7d764abc9a7294e8b5e91 (diff)
libcamera: Correctly report enabled ipa modules
"ipa_modules" stores the value of the ipas meson build option. IPAs are enabled if and only if there is an enabled pipeline for an IPA listed in "ipa_modules" array. It is basically the intersection of pipelines and ipa_modules array. In order to correctly report which IPAs get enabled, let's create a new array storing this intersection. Cc: Quentin Schulz <foss+libcamera@0leil.net> Reported-by: Daniel Semkowicz <dse@thaumatec.com> Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Jacopo Mondi <jacopo@jmondi.org> Signed-off-by: Jacopo Mondi <jacopo@jmondi.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3f7a3f56..e8b81ad8 100644
--- a/meson.build
+++ b/meson.build
@@ -173,7 +173,7 @@ py_mod.find_installation('python3', modules: py_modules)
## Summarise Configurations
summary({
'Enabled pipelines': pipelines,
- 'Enabled IPA modules': ipa_modules,
+ 'Enabled IPA modules': enabled_ipa_modules,
'Tracing support': tracing_enabled,
'Android support': android_enabled,
'GStreamer support': gst_enabled,