summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2022-07-06 15:10:16 -0400
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-07-07 00:53:16 +0300
commitba6435930f08e802cffc688d90f156a8959a0f86 (patch)
treeef88c3159ae378654df4388c39249b2bc607ac72 /meson.build
parented12bb4abaca50240178a5123f35dd01de8f484e (diff)
meson: Correctly pass the global include to the compiler
It's not safe to assume `-include config.h` works, since this depends on the functionality of the compiler that the cwd when running the compiler is searched first. When libcamera is included as a Meson subproject, the cwd of the compiler is the cwd of the main project, not of libcamera's build dir, and thus cannot be found. Instead, pass the include filename as a path based on the current build dir. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6d7d3ca6..3f7a3f56 100644
--- a/meson.build
+++ b/meson.build
@@ -44,7 +44,7 @@ endif
common_arguments = [
'-Wshadow',
- '-include', 'config.h',
+ '-include', meson.current_build_dir() / 'config.h',
]
c_arguments = []