summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-08-14 03:33:57 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2022-08-16 14:53:25 +0300
commitb954deff2071399ca941ffd719e762968f28feae (patch)
tree1e845095f3faec4834f3b1cdf5330846a6d26aa9 /meson.build
parentdfc6d711c9f7f0a9868afa5158aa2089163bded3 (diff)
meson: Use dependency() instead of find_library() where possible
Usage of find_library() to find dependencies that libcamera needs to compile against can lead to the library being found even if the corresponding headers are not installed. This will then result in a compilation failure. Switch to dependency() for libdw, libunwind and lttng-ust to fix this, all three libraries come with a pkgconfig file that is usually installed by the distribution package that contains the library headers. Reported-by: Christian Rauch <Rauch.Christian@gmx.de> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Paul Elder <paul.elder@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e8b81ad8..72919102 100644
--- a/meson.build
+++ b/meson.build
@@ -122,7 +122,7 @@ libcamera_includes = include_directories('include')
py_modules = []
# Libraries used by multiple components
-liblttng = cc.find_library('lttng-ust', required : get_option('tracing'))
+liblttng = dependency('lttng-ust', required : get_option('tracing'))
# Pipeline handlers
#