summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>2022-05-09 13:10:20 +0300
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-05-10 13:53:43 +0200
commit8aa02271fd716ed046970a0b1f89176963303f50 (patch)
treeda81430f03dc967addbdec3c143001b1490c751d /meson.build
parent5cb17e0c138aa3afef92e8d95d876d2bd94516ed (diff)
Add Python bindings
Add libcamera Python bindings. pybind11 is used to generate the C++ <-> Python layer. We use pybind11 'smart_holder' version to avoid issues with private destructors and shared_ptr. There is also an alternative solution here: https://github.com/pybind/pybind11/pull/2067 Only a subset of libcamera classes are exposed. Implementing and testing the wrapper classes is challenging, and as such only classes that I have needed have been added so far. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ea0a4200..6d7d3ca6 100644
--- a/meson.build
+++ b/meson.build
@@ -177,6 +177,7 @@ summary({
'Tracing support': tracing_enabled,
'Android support': android_enabled,
'GStreamer support': gst_enabled,
+ 'Python bindings': pycamera_enabled,
'V4L2 emulation support': v4l2_enabled,
'cam application': cam_enabled,
'qcam application': qcam_enabled,