summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>2022-05-09 13:10:17 +0300
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-05-10 13:53:43 +0200
commit68fd4b3c9137ddf2416f9dc82d3e1964fcbd5bfd (patch)
treef7bbb9ab0e4ca510634b08c40698d14242c0d23c /meson.build
parent6d990f102fd829feb05e37e5f242a796fcada1b5 (diff)
meson: Require meson 0.56+
Ubuntu 22.04 LTS has been released with meson 0.61.2, and it is easy to install a recent version of meson with python-pip, so let's update the required meson version to get rid of the Android compilation limitation. Additionally, going to meson 0.55 gives the ability to have patch files for git-wraps which is useful for Python bindings. 0.56 brings meson.project_source_root() and meson.project_build_root(), allowing us to get rid of the deprecated meson.source_root() and meson.build_root(). So, let's update the required meson version to 0.56. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com> Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 1 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 29d8542d..b892ba84 100644
--- a/meson.build
+++ b/meson.build
@@ -1,11 +1,7 @@
# SPDX-License-Identifier: CC0-1.0
project('libcamera', 'c', 'cpp',
- # Use of the Android component requires meson 0.55, but Ubuntu 20.04 LTS
- # ships meson 0.53. Improve the Ubuntu experience at the expense of
- # Android as the former is a much more common use case than the latter at
- # this point. This should be fixed after Ubuntu releases 22.04 LTS.
- meson_version : '>= 0.53',
+ meson_version : '>= 0.56',
version : '0.0.0',
default_options : [
'werror=true',